VMWare Vsphere web client is now the default access method after VMware has stopped desktop client to be able to access the VMWare ecosystem.
From Version 6.5 onward VMWare has made the webclient as default access method for managing the system. I deployed VSphere center to manage my lab ESXi environment. I faced a “blank white screen page” after I entered my credentials. After doing some look it seems that there is default method of access at registry level which causes this.
I made following changes:
Verify that the String (Default) value of the “HKEY_CLASSES_ROOT \.html” key is “htmlfile”

Select Start > Run.
In the Open box, type regedit, and then select OK.
Locate, and then click the following registry subkey:HKEY_CLASSES_ROOT \.html
Make sure that the value of the String (Default) is “htmlfile”. If it’s not “htmlfile”, right-click (Default), select Modify, input htmlfile in the Value data box, and then select OK.

After making changes I tried closing and opening the browser but issue was still there and I didn’t want to reset my browser settings:

In-case it doesn’t work you can clear all the cache in Chrome and if it still doesn’t work, Last resort for it was to try and reset the browser settings to their original defaults which worked. So to reset the browser settings to default you need to:

Open chrome > Open Settings > Show Advanced Settings > Reset browser Settings > Reset
Close Chrome and open again and if you was using self-signed certificates click “Proceed anyway”

Just a word of warning of reset browser settings where you will lose all your settings

Ref: https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1037183

Leave a Reply

Your email address will not be published. Required fields are marked *